Writing Jquery in xml file

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Writing Jquery in xml file

NishaK
Hello,

I am trying to develop a calendar widget for lotus connections. I have a html page which contains jquery to diaplay a calendar. This works fine. But when I try to put this html code into the xml file under cdata function the jquery gives me no output.

Here's the code snippet:
<iw:iwidget name="Calendar" xmlns:iw="http://www.ibm.com/xmlns/prod/iWidget" iScope="../fullcalendar.min">
<iw:resource uri="fullcalendar.min.js"/>
<iw:resource uri="jquery.js"/>
<iw:resource uri="jquery-ui-custom.js"/>
   
    <iw:content mode="view">
   
   
<![CDATA[    
        <h1>Hello<h1>
<head>
<link rel='stylesheet' type='text/css' href='fullcalendar.css' />
<script type='text/javascript' src='jquery.js'></script>
<script type='text/javascript' src='jquery-ui-custom.js'></script>
<script type='text/javascript' src='fullcalendar.min.js'></script>
<h2>Reached Here<h2>
<script type='text/javascript'>
alert("Inside Javascript");
    $(document).ready(function() {
    
        var date = new Date();
        var d = date.getDate();
        var m = date.getMonth();
        var y = date.getFullYear();
        
        var calendar = $('#calendar').fullCalendar({
            header: {
                left: 'prev,next today',
                center: 'title',
                right: 'basicWeek,basicDay'
            },
            selectable: true,
            editable: false
                    });
        
    });

</script>
<style type='text/css'>

    body {
        margin-top: 40px;
        text-align: center;
        font-size: 14px;
        font-family: "Lucida Grande",Helvetica,Arial,Verdana,sans-serif;
        }

    #calendar {
        width: 900px;
        margin: 0 auto;
        }

</style>
</head>
        <div id='calendar'>
Calendar Section

        </div>    
        
        ]]>
 
       
     </iw:content>
</iw:widget>


I wrote the print message just to see till where d code runs fine. All of them are printed so I think the only problem is jquery.

Please help.