Is the dialog.bgiframe option no longer necessary?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Is the dialog.bgiframe option no longer necessary?

Fontzter-2

It seems I had inadvertently left this option in some code after
upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
I'm assuming that this might be auto detected now.  Is that true?

thanks,  dave

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

Fontzter-2

Apparently, it is still needed.  Select boxes show through the dialog
in IE without it being set to true.  Could this be set to true by
default?  Or set to true by default if $.browser.msie?

On Jul 22, 11:58 am, Fontzter <[hidden email]> wrote:
> It seems I had inadvertently left this option in some code after
> upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> I'm assuming that this might be auto detected now.  Is that true?
>
> thanks,  dave
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

Richard D. Worth-2
I'm not sure it makes sense to set it to true by default because of the dependence on the bgiframe plugin, which is external. Scott, what do you think?

- Richard

On Fri, Jul 25, 2008 at 3:45 PM, Fontzter <[hidden email]> wrote:

Apparently, it is still needed.  Select boxes show through the dialog
in IE without it being set to true.  Could this be set to true by
default?  Or set to true by default if $.browser.msie?

On Jul 22, 11:58 am, Fontzter <[hidden email]> wrote:
> It seems I had inadvertently left this option in some code after
> upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> I'm assuming that this might be auto detected now.  Is that true?
>
> thanks,  dave



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

shelane

How do you set it to true? I don't see it in the docs.

On Jul 25, 12:51 pm, "Richard D. Worth" <[hidden email]> wrote:

> I'm not sure it makes sense to set it to true by default because of the
> dependence on the bgiframe plugin, which is external. Scott, what do you
> think?
>
> - Richard
>
> On Fri, Jul 25, 2008 at 3:45 PM, Fontzter <[hidden email]> wrote:
>
> > Apparently, it is still needed.  Select boxes show through the dialog
> > in IE without it being set to true.  Could this be set to true by
> > default?  Or set to true by default if $.browser.msie?
>
> > On Jul 22, 11:58 am, Fontzter <[hidden email]> wrote:
> > > It seems I had inadvertently left this option in some code after
> > > upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> > > I'm assuming that this might be auto detected now.  Is that true?
>
> > > thanks,  dave
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

Richard D. Worth-2
I'm not seeing it in the docs now either. I thought it was there. You set it like this (currently):

$("#myDiv").dialog({ bgiframe: true });

Requires you to have the bgiframe plugin also on the page. Scott and I will discuss this with the rest of the team and we'll come up with a plan. Thanks.

- Richard

On Fri, Jul 25, 2008 at 4:11 PM, Shelane <[hidden email]> wrote:

How do you set it to true? I don't see it in the docs.

On Jul 25, 12:51 pm, "Richard D. Worth" <[hidden email]> wrote:
> I'm not sure it makes sense to set it to true by default because of the
> dependence on the bgiframe plugin, which is external. Scott, what do you
> think?
>
> - Richard
>
> On Fri, Jul 25, 2008 at 3:45 PM, Fontzter <[hidden email]> wrote:
>
> > Apparently, it is still needed.  Select boxes show through the dialog
> > in IE without it being set to true.  Could this be set to true by
> > default?  Or set to true by default if $.browser.msie?
>
> > On Jul 22, 11:58 am, Fontzter <[hidden email]> wrote:
> > > It seems I had inadvertently left this option in some code after
> > > upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> > > I'm assuming that this might be auto detected now.  Is that true?
>
> > > thanks,  dave



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

Fontzter-2
In reply to this post by Richard D. Worth-2

Would it make sense to check for the existence of the bgiframe plugin
and set it to true if $.browser.msie?

The defaults aren't that big of a deal.  I just saw that it was gone
from the documentation, assumed it was no longer needed and removed it
from my code.  I guess it just needs to go back in the docs really.

Thanks,

Dave


On Jul 25, 3:51 pm, "Richard D. Worth" <[hidden email]> wrote:

> I'm not sure it makes sense to set it to true by default because of the
> dependence on the bgiframe plugin, which is external. Scott, what do you
> think?
>
> - Richard
>
> On Fri, Jul 25, 2008 at 3:45 PM, Fontzter <[hidden email]> wrote:
>
> > Apparently, it is still needed.  Select boxes show through the dialog
> > in IE without it being set to true.  Could this be set to true by
> > default?  Or set to true by default if $.browser.msie?
>
> > On Jul 22, 11:58 am, Fontzter <[hidden email]> wrote:
> > > It seems I had inadvertently left this option in some code after
> > > upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> > > I'm assuming that this might be auto detected now.  Is that true?
>
> > > thanks,  dave
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Is the dialog.bgiframe option no longer necessary?

livefree75
In reply to this post by Richard D. Worth-2
Question:

Does the dialog (or bgiframe plugin itself) automatically detect the existence of IE <=6.0, and only insert the IFRAME in those cases?  I checked it out in IE7 (using DebugBar, which I don't prefer), and FF, and didn't see an IFRAME, but I wanted to ask you guys, who may know for sure.

Thanks,
Jamie


Richard D. Worth-2 wrote
I'm not seeing it in the docs now either. I thought it was there. You set it
like this (currently):

$("#myDiv").dialog({ bgiframe: true });

Requires you to have the bgiframe plugin also on the page. Scott and I will
discuss this with the rest of the team and we'll come up with a plan.
Thanks.

- Richard

On Fri, Jul 25, 2008 at 4:11 PM, Shelane <senos@llnl.gov> wrote:

>
> How do you set it to true? I don't see it in the docs.
>
> On Jul 25, 12:51 pm, "Richard D. Worth" <rdwo...@gmail.com> wrote:
> > I'm not sure it makes sense to set it to true by default because of the
> > dependence on the bgiframe plugin, which is external. Scott, what do you
> > think?
> >
> > - Richard
> >
> > On Fri, Jul 25, 2008 at 3:45 PM, Fontzter <dmfo...@gmail.com> wrote:
> >
> > > Apparently, it is still needed.  Select boxes show through the dialog
> > > in IE without it being set to true.  Could this be set to true by
> > > default?  Or set to true by default if $.browser.msie?
> >
> > > On Jul 22, 11:58 am, Fontzter <dmfo...@gmail.com> wrote:
> > > > It seems I had inadvertently left this option in some code after
> > > > upgrading (now at 1.5.2).  I didn't see it in the API docs anymore.
> > > > I'm assuming that this might be auto detected now.  Is that true?
> >
> > > > thanks,  dave
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery UI" group.
To post to this group, send email to jquery-ui@googlegroups.com
To unsubscribe from this group, send email to jquery-ui-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/jquery-ui?hl=en
-~----------~----~----~----~------~----~------~--~---