Basic use of jQuery doesn't work

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Basic use of jQuery doesn't work

Dva Wolk

Hi!
I was struggling for a whole day with cycle plugins but to no avail.
Now i tried to go to the basics, but still what am i missing, since
jquery doesn't work for me.
I have this string on the page:

$("#ena").hide("slow");

Just to try something basic,to see what am i doing wrong... When i
click the button, the blue div (#ena) on the page should be slowly
hidden, but it is not...

My site is on hostmonster.
And it can be seen here:

http://belivolk.info/plugin.html

Please, help, there should be something wrong, but i am missing it...
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery Plugins" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-plugins?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Basic use of jQuery doesn't work

kouphax

The plugin uses jquery so it needs to be delcared before the plugin
 
<script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
 
not
 
 
<script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
 
________________________________

From: [hidden email] on behalf of Dva Wolk
Sent: Thu 08/01/2009 08:59
To: jQuery Plugins
Subject: [plugins] Basic use of jQuery doesn't work




Hi!
I was struggling for a whole day with cycle plugins but to no avail.
Now i tried to go to the basics, but still what am i missing, since
jquery doesn't work for me.
I have this string on the page:

$("#ena").hide("slow");

Just to try something basic,to see what am i doing wrong... When i
click the button, the blue div (#ena) on the page should be slowly
hidden, but it is not...

My site is on hostmonster.
And it can be seen here:

http://belivolk.info/plugin.html

Please, help, there should be something wrong, but i am missing it...




--------------------------------------------------------------------
This e-mail is intended solely for the addressee and is strictly confidential; if you are not the addressee please destroy the message and all copies. Any opinion or information contained in this email or its attachments that does not relate to the business of Kainos
is personal to the sender and is not given by or endorsed by Kainos. Kainos is the trading name of Kainos Software Limited, registered in Northern Ireland under company number: NI19370, having its registered offices at: Kainos House, 4-6 Upper Crescent, Belfast, BT7 1NT,
Northern Ireland. Registered in the UK for VAT under number: 454598802 and registered in Ireland for VAT under number: 9950340E. This email has been scanned for all known viruses by MessageLabs but is not guaranteed to be virus free; further terms and conditions may be
found on our website - www.kainos.com



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery Plugins" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-plugins?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Basic use of jQuery doesn't work

Dva Wolk
Hi!

Ok, now...
this one:
http://belivolk.info/plugin.html

uses just commands from jquery (not a plugin) i changed the src order as James said, but still nothing new. It doesn't work for me. what am i missing?

Also, i tried this thing. I transffered whole page from
http://malsup.com/jquery/cycle/

to
http://belivolk.info/Plug.htm

as for jquery and jquery plugin, all is the same... but it doesn't work at my place!
How can that be possible?

Should be there any permissions on the jquery files applied? The folder has 755 and the files have 644...

Regards, Klemen



2009/1/8 James Hughes <[hidden email]>

The plugin uses jquery so it needs to be delcared before the plugin

<script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>

not


<script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
<script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>

________________________________

From: [hidden email] on behalf of Dva Wolk

Hi!
I was struggling for a whole day with cycle plugins but to no avail.
Now i tried to go to the basics, but still what am i missing, since
jquery doesn't work for me.
I have this string on the page:

$("#ena").hide("slow");

Just to try something basic,to see what am i doing wrong... When i
click the button, the blue div (#ena) on the page should be slowly
hidden, but it is not...

My site is on hostmonster.
And it can be seen here:

http://belivolk.info/plugin.html

Please, help, there should be something wrong, but i am missing it...


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery Plugins" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-plugins?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Basic use of jQuery doesn't work

kouphax

$("#ena").hide("slow"); is being performed before the page is loaded so that node doesn't exist yet - try this
 
$(function(){
    $("#ena").hide("slow");
})
 
James Hughes | Senior Software Engineer | Kainos | M: +44 (0) 7596768043 | [hidden email]
 
P Please consider the environment and do not print this mail unless necessary

________________________________

From: [hidden email] on behalf of Klemen
Sent: Thu 08/01/2009 09:48
To: [hidden email]
Subject: [plugins] Re: Basic use of jQuery doesn't work


Hi!

Ok, now...
this one:
http://belivolk.info/plugin.html

uses just commands from jquery (not a plugin) i changed the src order as James said, but still nothing new. It doesn't work for me. what am i missing?

Also, i tried this thing. I transffered whole page from
http://malsup.com/jquery/cycle/

to
http://belivolk.info/Plug.htm

as for jquery and jquery plugin, all is the same... but it doesn't work at my place!
How can that be possible?

Should be there any permissions on the jquery files applied? The folder has 755 and the files have 644...

Regards, Klemen




2009/1/8 James Hughes <[hidden email]>



        The plugin uses jquery so it needs to be delcared before the plugin
       
        <script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
        <script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
        <script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
       
        not
       
       
        <script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
        <script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
        <script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
       
        ________________________________
       
        From: [hidden email] on behalf of Dva Wolk

        Hi!
        I was struggling for a whole day with cycle plugins but to no avail.
        Now i tried to go to the basics, but still what am i missing, since
        jquery doesn't work for me.
        I have this string on the page:
       
        $("#ena").hide("slow");
       
        Just to try something basic,to see what am i doing wrong... When i
        click the button, the blue div (#ena) on the page should be slowly
        hidden, but it is not...
       
        My site is on hostmonster.
        And it can be seen here:
       
        http://belivolk.info/plugin.html
       
        Please, help, there should be something wrong, but i am missing it...
       






--------------------------------------------------------------------
This e-mail is intended solely for the addressee and is strictly confidential; if you are not the addressee please destroy the message and all copies. Any opinion or information contained in this email or its attachments that does not relate to the business of Kainos
is personal to the sender and is not given by or endorsed by Kainos. Kainos is the trading name of Kainos Software Limited, registered in Northern Ireland under company number: NI19370, having its registered offices at: Kainos House, 4-6 Upper Crescent, Belfast, BT7 1NT,
Northern Ireland. Registered in the UK for VAT under number: 454598802 and registered in Ireland for VAT under number: 9950340E. This email has been scanned for all known viruses by MessageLabs but is not guaranteed to be virus free; further terms and conditions may be
found on our website - www.kainos.com



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery Plugins" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-plugins?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: Basic use of jQuery doesn't work

Dva Wolk
GREAT!
now the first one works... Thank you, very,very much...

But the second still doesn't...
http://belivolk.info/Plug.htm

it should work like:
http://malsup.com/jquery/cycle/

What is the problem here?

Looking forward to solution,
Klemen


2009/1/8 James Hughes <[hidden email]>

$("#ena").hide("slow"); is being performed before the page is loaded so that node doesn't exist yet - try this

$(function(){
   $("#ena").hide("slow");
})

James Hughes | Senior Software Engineer | Kainos | M: +44 (0) 7596768043 | [hidden email]

P Please consider the environment and do not print this mail unless necessary

________________________________

From: [hidden email] on behalf of Klemen
Sent: Thu 08/01/2009 09:48
To: [hidden email]
Subject: [plugins] Re: Basic use of jQuery doesn't work


Hi!

Ok, now...
this one:
http://belivolk.info/plugin.html

uses just commands from jquery (not a plugin) i changed the src order as James said, but still nothing new. It doesn't work for me. what am i missing?

Also, i tried this thing. I transffered whole page from
http://malsup.com/jquery/cycle/

to
http://belivolk.info/Plug.htm

as for jquery and jquery plugin, all is the same... but it doesn't work at my place!
How can that be possible?

Should be there any permissions on the jquery files applied? The folder has 755 and the files have 644...

Regards, Klemen




2009/1/8 James Hughes <[hidden email]>



       The plugin uses jquery so it needs to be delcared before the plugin

       <script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>
       <script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
       <script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>

       not


       <script type="text/javascript" src="http://belivolk.info/jquery/jquery.cycle.all.js"></script>
       <script type="text/javascript" src="http://belivolk.info/jquery/chili-1.7.pack.js"></script>
       <script type="text/javascript" src="http://belivolk.info/jquery/jquery-1.2.6.js"></script>

       ________________________________

       From: [hidden email] on behalf of Dva Wolk

       Hi!
       I was struggling for a whole day with cycle plugins but to no avail.
       Now i tried to go to the basics, but still what am i missing, since
       jquery doesn't work for me.
       I have this string on the page:

       $("#ena").hide("slow");

       Just to try something basic,to see what am i doing wrong... When i
       click the button, the blue div (#ena) on the page should be slowly
       hidden, but it is not...

       My site is on hostmonster.
       And it can be seen here:

       http://belivolk.info/plugin.html

       Please, help, there should be something wrong, but i am missing it...







--------------------------------------------------------------------
This e-mail is intended solely for the addressee and is strictly confidential; if you are not the addressee please destroy the message and all copies. Any opinion or information contained in this email or its attachments that does not relate to the business of Kainos
is personal to the sender and is not given by or endorsed by Kainos. Kainos is the trading name of Kainos Software Limited, registered in Northern Ireland under company number: NI19370, having its registered offices at: Kainos House, 4-6 Upper Crescent, Belfast, BT7 1NT,
Northern Ireland. Registered in the UK for VAT under number: 454598802 and registered in Ireland for VAT under number: 9950340E. This email has been scanned for all known viruses by MessageLabs but is not guaranteed to be virus free; further terms and conditions may be
found on our website - www.kainos.com






--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "jQuery Plugins" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/jquery-plugins?hl=en
-~----------~----~----~----~------~----~------~--~---